Data Connection seems not to work?

I can’t get data connection to work. Every url api I try to fetch fails due to a CORS issue (perhaps)

Http failure response for https://swapi.dev/api/people/2: 0 Unknown Error. This could be a CORS issue - try configuring your server to allow requests

I tried some different APIs as i thought it might be an issue with my (working) server.

hi @Heiko,

could you please send:

  • the screenshot with the http request settings
  • open Devtools -> Network -> Select the needed request and attach the screenshot here

Sure.
I can’t see any special here :frowning: I am using this (and other services) now for some time in different places (tutorials and such) and thus I am surprised that they don’t work now.

Thank you. We also need the screenshot of the settings of the http request step in UI Bakery, and the other steps of action. We suppose the problem may be there.

That’s wierd. I set up a new blank project, just a button and text field and I could retrieve data from swapi.dev.
Then I changed the service (my own server) and this didn’t work (CORS error, this time correct, not configured yet), then setting back to the swapi.dev service, it stopped working

@Heiko
“Then I changed the service (my own service)”… - did you mean “server” here?
If yes, please check if CORS is enabled on your server (this may be useful - https://developer.mozilla.org/en-US/docs/Web/HTTP/CORS).
And please inform me on the results :slight_smile:

Yes, my own server (I tend to call API’s sometimes as services, as I am old bloke from the Java-World)
With enabled CORS it works, and thanks to Artem, we found a way for other APIs to get them running.

At the end, it’s not a big deal, but when you start trying a new product and you get errors where haven’t had errors for years (with other products) one gets easily frustrated. :slight_smile:

1 Like

Yeah, I can easily understand your frustration, sorry about that!

@Heiko could you please share the link to your project with me? In direct messages.
Thanks!

@ev_jennie Sure. Sent a direct message.

I have a similar issue and it was suggested I proxy the request, although I don’t understand why
https://community.uibakery.io/t/authorization-in-http-get/76

1 Like

It’s a bit of a strange one for me, too.

For playing around I used my own server with a simple JSON response and got CORS issues, however, I have some other Angular / Ionic Projects who work just fine. But to be honest, the server didn’t have CORS enabled, after I did this, the UIbakery project worked. I couldn’t get many more API to work, except using the Heroku-Proxy, but that’s not a final solution.